Project Parser and Browser

TIDE features a project parser that continuously scans through the project as you edit it. The parser's job is to "catalog things": keep track of your procedures (functions), variables, constants, and so on.

The parser is much more forgiving than the compiler: it tries to skip things that it doesn't understand.

Below are some of the notable features that the parser brings to TIDE:

gear_iconNote: The parser's behavior can be adjusted in the TIDE Preferences dialog ( File > TIDE Preferences > Editor > General, Tibbo BASIC, TIBBO C)

Project browser

browser-project

Click here to open full-size image in a new window.

The fruits of the parser's labor are displayed in the Project Browser Pane ( View > Browser-Project).

This pane is an indispensable tool for navigating your project, as well as learning about resources (objects, syscalls, etc.) offered by the selected platform. For more information, please refer to Browser-Project Pane.

File browser

file_pane

There is also a File Browser Pane ( View > Browser > File), which is very useful for navigating the current file you are editing. For more information, please refer to Browser-File Pane.

Teleporting with [CTRL]+click

teleport

[CTRL]+click on a procedure, variable, constant, etc. in the source code: You will teleport to this item's definition.

[CTRL]+mouse over a procedure to pop a call tree window, the same one that shows in the project browser.

Auto-complete

auto_completion

The Parser displays a list of suggestions as you type.

Hinting

hints

Mouse over things to get "quick info" tooltips, which can even be displayed for your own procedures (functions).

Automatic insertion of code snippets

Standard language constructs get completed for your automatically. For example:

snippet universal_search

Our pride! Type anything and see the depth of suggested items and actions!

Think it's all obvious? Some things to try:

  • Input the name of a file in your project

  • Type a line number

Procedure separators (delimiters)

TIDE draws a separator line after procedures and some other constructs to improve readability.

This feature can be disabled separately for Tibbo BASIC and C — see the TIDE Preferences page ( File > TIDE Preferences > Editor > Tibbo BASIC, Tibbo C).

When the procedure delimiters are set to smart, you can override the "automatic" line by adding a comment line containing three or more repeating characters (and, optionally, spaces).

It doesn't matter what character you use, as long as the same character repeats at least three times and there are no other characters in this comment (except spaces), as shown below.

procedure delimiters