Working With TIDE Projects

Top  Previous  Next

Every application you develop in TIDE exists as a project.

A project is a collection of related files (plus project settings). It is customary to have a separate project folder for each project.

Here is the structure of a typical project, as shown by the Files pane of TIDE (View > Files):

 

files pane

 

tide_icon_tprEach project is described by a project file with the .TPR extension.

The project file lists all other files in the project, along with their types.

It also keeps track of the selected platform, as well as the target device's address (more).

There is also a second project file with the .TPRUSR extension. It remembers the project state (breakpoints, opened files, cursor positions in files, etc.). This file is "expendable". TIDE will (re)create it if this file isn't found.  

 

tide_button_newprojectTo start a new project, select File > New Project. This will create a new project folder and a .TPR file with the same name.

There are several important things you need to select, one of which is the platform. See the New Project dialog for details.

 

tide_button_openprojectTo open an existing project, select File > Open Project and pick the .TPR file of the project you want to open.

TIDE does not allow you to open and edit standalone files, i.e. files that do not belong to any project.

tide_button_projectsettings

You can always change the target platform and other project parameters through the Project Settings dialog (File > Project Settings).