Project Parser and Browser

Top  Previous  Next

TIDE features a project parser. The parser continuously scans through the project as you edit it.

The parser's job is to "catalog things": keep track of your procedures (functions), variables, constants, and so on.

Compared to the compiler, the parser is much more forgiving: it tries to skip over things it doesn't understand.

Here are some notable features that the parser brings to TIDE.

gear_icon

Parser behavior can be adjusted in the TIDE Preferences dialog (File > TIDE Preferences —> Editor —> General, Tibbo BASIC, Tibbo C).

 

Project browser

Click to enlarge
Click to enlarge

The fruits of the parser's labor are displayed in the Project Browser Pane (View > Browser-Project).

This pane is an indispensable tool for navigating your project, as well as learning about resources (objects, syscalls, etc.) offered by the selected platform.

Learn more about the Project Browser pane by following this link

 

 

File browser

Click to enlarge
Click to enlarge

There is also a File Browser Pane (View > Browser > File).

It is very useful for navigating the current file you are editing.

Learn more about the File Browser pane by following this link

 

 

Teleporting with [CTRL]+click

[CTRL]+click on a procedure, variable, constant, etc. in the source code. You will teleport to this item's definition.

[CTRL]+mouse over a procedure will pop a call tree window, the same one that shows in the project browser.

 

teleport

 

Auto-complete

The Parser displays a list of suggestions as you type.

 

auto_completion

 

Hinting

Mouse-over things to get "quick info" tooltips. Such tooltips can even be displayed for your own procedures (functions).

 

hints

 

Automatic insertion of code snippets

Standard language constructs get completed for your automatically. For example:

 

snippet

 

Universal search

Our pride! Type anything and see the depth of suggested items and actions!

Think it's all obvious? Some things to try:

Input a name of the file from your project
Type a line number

universal_search

 

Procedure separators (delimiters)

TIDE draws a separator line after procedures and some other constructs. This improves readability.

This feature may be disabled separately for BASIC and C — see TIDE Preferences page (File > TIDE Preferences —> Editor —> Tibbo BASIC, Tibbo C).

When the procedure delimiters are set to smart you can override the "automatic" line by adding a comment line containing three or more repeating characters (and, optionally, spaces).

It doesn't matter what character you use, as long as the same character repeats at least three times and there are no other characters in this comment (except spaces):

 

procedure delimiters